Publish VTB issue

Incident Report for TravelSpirit

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 11:18 CET

Investigating

We are facing an issue in regards to the publication of VTB's. We are currently investigating the issue.
Posted Oct 30, 2025 - 10:58 CET
This incident affected: Visual Tour Builder.