Performance issue

Incident Report for TravelSpirit

Resolved

This incident has been resolved.
Posted Dec 01, 2025 - 16:37 CET

Investigating

We are currently investigating some performance issues.
Posted Dec 01, 2025 - 16:01 CET
This incident affected: TravelSpirit Backoffice & CRM.