Performance issue

Incident Report for TravelSpirit

Resolved

Performance should be as expected again
Posted Dec 01, 2025 - 15:39 CET

Investigating

We are currently investigating some performance issues
Posted Dec 01, 2025 - 15:28 CET
This incident affected: TravelSpirit Backoffice & CRM.