The scheduled maintenance has been completed and we're now live on Version 3.40.0 . Please check the release notes for changes and new features: https://releasenotes.travelspirit.nl/
Posted Jun 01, 2026 - 20:31 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2026 - 19:00 CEST
Scheduled
We will be updating TravelSpirit to the newest version (3.40.0). The application might be temporarily unavailable during this time.
Posted May 18, 2026 - 14:31 CEST
This scheduled maintenance affected: TravelSpirit Backoffice & CRM, Visual Tour Builder, and MediaSpirit.