Degraded performance

Incident Report for TravelSpirit

Resolved

The performance issues have been resolved. Everything should work again as expected. We will write a post-mortem and post this on this statuspage.
Posted Jul 13, 2026 - 13:12 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 13, 2026 - 11:11 CEST

Investigating

We are currently investigating some degraded performance. We will update you via this page.
Posted Jul 13, 2026 - 09:18 CEST
This incident affected: TravelSpirit Backoffice & CRM.