Degraded performance for sending mails

Incident Report for TravelSpirit

Resolved

eMail sending has now been fully restored. The backlog of unsent emails will be processed very soon.
Posted Dec 03, 2025 - 17:10 CET

Identified

AWS Simple eMail Service has a disruption in service which has fully stopped our eMail sending capabilities. We expect to receive more information in the next 1-2 hours.
Posted Dec 03, 2025 - 16:38 CET

Investigating

We are currently investigating an email sending related issue. We will update this page if there is any news.
Posted Dec 03, 2025 - 15:36 CET
This incident affected: TravelSpirit Backoffice & CRM.