Performance issue - Mail

Incident Report for TravelSpirit

Resolved

The issue has been resolved, all should function as expected
Posted Jun 03, 2026 - 10:28 CEST

Investigating

We are currently investigating an issue regarding the mail module, this might result in delay of sending out email/handling mail. We will update this page with the latest info.
Posted Jun 03, 2026 - 10:18 CEST
This incident affected: TravelSpirit Backoffice & CRM.